设为首页收藏本站 官方微信

创幻股票

 找回密码
 注册

QQ登录

只需一步,快速开始

扫一扫,访问微社区

查看: 161881|回复: 1609

通达信买主升浪指标公式 {更新}

  [复制链接]

已领礼包: 149个

财富等级: 日进斗金

发表于 2011-1-22 10:07 | 显示全部楼层 |阅读模式
本帖最后由 跌声一片 于 2011-4-22 19:16 编辑

VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
持币区域:VAR1,COLORFEDCBA;
持股区域:IF(VAR1>0,VAR1,0),COLORRED;
短顶:VAR1>9 AND FILTER(VAR1<REF(VAR1,1),5),COLORGREEN;
大顶:VAR1>20 AND FILTER(VAR1<REF(VAR1,1),5),COLOR00FF00;
VAR2:=HHV(VAR1>20,10);
危险: VAR2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20));
注意止损:VAR2 AND FILTER(VAR1< REF(VAR1,1),6)
AND CROSS(MA(CLOSE,5),MA(CLOSE,2));
短底:VAR1<-9 AND VAR1> REF(VAR1,1),COLORRED;
大底:VAR1<-20 AND FILTER(VAR1> REF(VAR1,1),5),COLORYELLOW;
买入准备:VAR1<-9 AND VAR1>REF(VAR1,1),COLORWHITE;
DRAWTEXT(VAR1>9 AND FILTER(VAR1<REF(VAR1,1),5),VAR1+2,'短顶'),COLOR00FF00;
DRAWTEXT(VAR1>20 AND FILTER(VAR1<REF(VAR1,1),5),VAR1+5,'大顶'),COLORFFFF00;
DRAWTEXT(VAR2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),VAR1+10,'危险'),COLOR00FFFF;
DRAWTEXT(VAR2 AND FILTER(VAR1< REF(VAR1,1),6) AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VAR1+6,'注意止损'),COLORFF00FF;
DRAWTEXT(FILTER(VAR1<-9 AND VAR1>REF(VAR1,1),18),VAR1-2,'短底'),COLOR0000FF;
DRAWTEXT(VAR1<-20 AND FILTER(VAR1> REF(VAR1,1),5),VAR1-5,'大底');
DRAWTEXT(FILTER(VAR1<-9 AND VAR1>REF(VAR1,1),18),1,'买入准备');






授人以鱼不如授人以渔
论坛的朋友们:我们都来至于全国的五湖四海,现在都汇聚在论坛。大家在这里相互交流,相互学习,共同进步!
如何选好一个股票有为关键,选择一个好的股票,将是成功的一半!
每个人有每个的思路,对股票市场也是一样!现在将股票市场的历史走势以统计学的原理分析!(看帖是缘,回帖是礼!!)





==================================================================================================

VAR3:=LLV(HIGH,240);
VAR4:=((100 * (CLOSE - VAR3)) / VAR3);
VAR5:=REF(LLV(CLOSE,480),1);
VAR6:=REF(HHV(CLOSE,480),1);
VAR7:=(100 * (CLOSE - VAR5))/(VAR6 - VAR5);
VAR8:=((CLOSE-LLV(CLOSE,981))/(HHV(CLOSE,981)- LLV(CLOSE,981))) * 100;
VAR9:=((CLOSE-LLV(CLOSE,393))/(HHV(CLOSE,393)- LLV(CLOSE,393))) * 100;
VARA:=((CLOSE-LLV(LOW,981))/(HHV(HIGH,981)- LLV(LOW,981))) * 100;
VARB:=((CLOSE-LLV(LOW,393))/(HHV(HIGH,393)- LLV(LOW,393))) * 100;
VARC:=EMA(((100*(CLOSE-LLV(LOW,100)))/(HHV(HIGH,100)-LLV(LOW,100))),5)/4;
VARE:=VARC<1;
VAR10:=((VAR4<0) AND (VAR7 < 0));
VAR12:=((((HIGH + LOW) + (CLOSE * 2)) / 4));
VAR13:=EMA(VAR12,21);
VAR14:=STD(VAR12,21);
VAR15:=((((((VAR12 - VAR13) / VAR14) * 100) + 200) / 4));
VAR16:=(EMA(VAR15,89) - 25) * 1.56;
VAR17:=EMA(VAR16,5) * 1.22;
VAR18:=EMA(VAR17,3);
VAR19:=3*VAR17 - 2*VAR18;
VAR1A:=IF(((CROSS(VAR19,VAR17) AND CROSS(VAR19,VAR18)) AND CROSS(VAR17,VAR18)),1,0);
VAR1B:=IF(((CROSS(VAR17,VAR19) AND CROSS(VAR18,VAR19)) AND CROSS(VAR18,VAR17)),1,0);
买点:IF((FILTER(((((VAR8=0) AND VARE) AND VAR10) AND VAR1A),5) = 1),10,0),COLOR0000FF;
卖点:IF(FILTER(VAR8=100 AND VAR1B,5)=1,10,0),COLOR00FF00;
VAR1C:=(EMA(((100*(CLOSE-LLV(LOW,100)))/(HHV(HIGH,100)-LLV(LOW,100))),13) / 4);
VAR1D:=(EMA(CLOSE,2) - EMA(CLOSE,89));
VAR1E:=EMA(VAR1D,30);
VAR1F:=((2 * (VAR1D - VAR1E)) * 10);
VAR20:=((POW(VAR1F,3) * 0.1) + POW(VAR1F,2));
VAR21:=SQRT(SQRT((((LOW * HIGH) * OPEN) * CLOSE)));
VAR22:=EMA((VAR21 * 0.97),3);
VAR23:=(((HIGH + LOW) + CLOSE) / 3);
VAR24:=((VAR23 - MA(VAR23,14)) / (0.015 * AVEDEV(VAR23,14)));
VAR25:=(IF(((YEAR < 2008) AND (VAR1F > 0.015)),VAR20,0) / 45);
庄拉线:VAR25,COLOR00FFFF;
VAR26:=(EMA(CLOSE,2) - EMA(CLOSE,150));
VAR27:=EMA(VAR26,100);
VAR28:=(2 * (VAR26 - VAR27));
VAR29:=((POW(VAR28,3) * 0.1) + POW(VAR28,1));
VAR2A:=SQRT(SQRT((LOW * HIGH * OPEN * CLOSE)));
VAR2B:=EMA(VAR2A * 0.97,3);
VAR2C:=(HIGH + LOW + CLOSE) / 3;
VAR2D:=(VAR2C - MA(VAR2C,14)) / (0.015 * AVEDEV(VAR2C,14));
黑马线:IF((VAR28 > 0.1),VAR29,0) * 5,COLOR0000FF;
量价线:((CLOSE-MA(CLOSE,21))/MA(CLOSE,21))*100,COLORFFFFFF;
VAR2E:=IF(FILTER(量价线>0 AND 量价线<3,5)=1,12,0);
涨幅前兆:IF(FILTER(庄拉线>0 AND 庄拉线<0.5 AND VAR2E AND VAR1C<3,10)=1,10,0),COLORFFFFFF;
选股利器:IF(FILTER(VAR2E>0 AND VAR1C<2 AND 庄拉线>0 AND 庄拉线<1 AND 黑马线>0 AND 黑马线<1.5 AND VAR2E>0,5)=1,10,0),COLORFF00FF;
量价先行:7*CROSS(量价线,0),COLOR00FF00;
拉升开始:12*(庄拉线>0.1 AND COUNT(庄拉线>0.1,2)=1 AND CLOSE>=OPEN AND VOL>REF(VOL,1) AND VOL/CAPITAL>0.003 AND 量价线>1 AND 量价线>黑马线),LINETHICK2,COLOR00FFFF;
量价主升浪:18*FILTER(CROSS(量价线,黑马线) AND 庄拉线>0.5,7),LINETHICK3,COLOR00FF00;
庄拉主升浪:20*(CROSS(庄拉线,黑马线) AND 黑马线>0 AND 量价线>0),LINETHICK3,COLOR0000FF;
DRAWICON((买点 > 0),10,1);
DRAWICON((卖点 > 0),10,2);
DRAWICON((涨幅前兆 > 0),10,1);
DRAWICON((选股利器 > 0),10,1);
DRAWICON(量价先行 > 0,10,10);
DRAWICON(拉升开始 > 0,15,10);
DRAWICON(量价主升浪> 0,20,9);
DRAWICON(庄拉主升浪 > 0,30,9);

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?注册

x

评分

参与人数 1人气 +6 收起 理由
新宇东方 + 6 谢谢分享

查看全部评分

回复

使用道具 举报

已领礼包: 293个

财富等级: 日进斗金

发表于 2011-1-22 15:54 | 显示全部楼层
此帖仅作者可见

使用道具 举报

已领礼包: 149个

财富等级: 日进斗金

 楼主| 发表于 2011-1-23 23:10 | 显示全部楼层
此帖仅作者可见

使用道具 举报

已领礼包: 9个

财富等级: 恭喜发财

发表于 2011-1-23 23:26 | 显示全部楼层
此帖仅作者可见

使用道具 举报

发表于 2011-1-23 23:40 | 显示全部楼层
此帖仅作者可见

使用道具 举报

头像被屏蔽

已领礼包: 1086个

财富等级: 财源广进

发表于 2011-1-24 06:56 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽

使用道具 举报

已领礼包: 3314个

财富等级: 富可敌国

发表于 2011-1-24 09:44 | 显示全部楼层
此帖仅作者可见

使用道具 举报

头像被屏蔽

已领礼包: 223个

财富等级: 日进斗金

发表于 2011-1-25 12:22 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽

使用道具 举报

发表于 2011-1-25 12:48 | 显示全部楼层
此帖仅作者可见

使用道具 举报

已领礼包: 41个

财富等级: 招财进宝

发表于 2011-1-25 12:54 | 显示全部楼层
此帖仅作者可见

使用道具 举报

头像被屏蔽
发表于 2011-1-25 13:42 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽

使用道具 举报

已领礼包: 149个

财富等级: 日进斗金

 楼主| 发表于 2011-1-25 15:18 | 显示全部楼层
此帖仅作者可见

使用道具 举报

发表于 2011-1-25 16:09 | 显示全部楼层
此帖仅作者可见

使用道具 举报

发表于 2011-1-25 17:25 | 显示全部楼层
此帖仅作者可见

使用道具 举报

已领礼包: 1个

财富等级: 恭喜发财

发表于 2011-1-25 19:20 | 显示全部楼层
此帖仅作者可见

使用道具 举报

发表回复

您需要登录后才可以回帖 登录 | 注册

本版积分规则


广告
快速回复 返回顶部 返回列表